[talk-ch] Dam does not render

Michael Kleidt m_kleidt at bluewin.ch
Sat Aug 31 16:42:33 CEST 2013


Am 31.08.2013 15:48, schrieb Mohamed Ellozy:
> I have attempted to change a dam from a simple way to an area to allow 
> me to add a path crossing it [1].  So I took the original way, added 
> nodes to make it an area, put steps going down from the upper road, a 
> path across the dam joining the steps to the lower road.  The steps 
> and the path render properly, and the name of the dam shows, but not 
> the dam itself.
>
> What can I do to make the dam render properly?
>
> Many thanks
>
> Mohamed (RetiredInNH)
>
> [1] http://www.openstreetmap.org/#map=19/46.46421/7.06530
>
>
> _______________________________________________
> talk-ch mailing list
> talk-ch at openstreetmap.ch
> http://lists.openstreetmap.ch/mailman/listinfo/talk-ch
Hallo Mohamed,

your tagging is correct. According to the wiki-page you even don't need 
area=yes, because closed ways should automatically handled as areas.

The problem is the rendering style or mapnik itself. There is not ONE 
correct rendering style, but every map could have his own style. Every 
map can decide what to render and what to ignore. But in this case you 
are talking about the style from openstreetmap.org. This syle renders 
waterway=dam as a way, but not as an area. This could be an error. 
Errors in this rendering syte can be reported at 
https://trac.openstreetmap.org. in this case this problem is already 
reported two years ago: https://trac.openstreetmap.org/ticket/3985

So you should not change the OSM data, but you can try to force the bug 
report or provide your own patch :-). Or just wait and hope sombody else 
will fix the problem in the future ...

regards

mdk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.ch/pipermail/talk-ch/attachments/20130831/a0393b04/attachment-0001.html>


More information about the talk-ch mailing list