[talk-ch] Unique constraint violation during import with osm2pgsql

Rémi Bovard remi.bovard at gmail.com
Wed Oct 5 16:33:09 CEST 2016


Hi Sarah,

Thanks a lot for the tip, it worked as expected.

I don't remember from where I got my version but using a more recent one
made it!

Best regards,

Rémi


> I cannot find that specific version in the official git repos, so
> maybe this is some hacked versoin of osm2pgsql? The command line
> at least looks okay, I tried with pretty much the same command.
>
> I've also checked the pbf and it doesn't contain any duplicates,
> so osm2pgsql is wrong here. Maybe it isn't properly deleting the
> nodes table before starting the import. Normally it should drop
> and recreate table.
>
> In any case, I would recommend to try with a newer version of
> osm2pgsql. Either the 0.90.1 release or the newest source from
> github.
>
> Kind regards
>
> Sarah
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.ch/pipermail/talk-ch/attachments/20161005/847f06cc/attachment-0002.html>


More information about the talk-ch mailing list